High Connections on Apps API

Incident Report for ThreatLocker

Resolved

We have been monitoring for a number of days and have not seen further issues.
Posted Aug 24, 2026 - 20:09 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2026 - 16:41 UTC

Investigating

We are experiencing high connection requests to our Application APIs. While this is being investigated and resolved you may experience small delays with application definition downloads.
Posted Aug 12, 2026 - 15:15 UTC
This incident affected: Apps APIs.