Instance H Performance Issues

Incident Report for ThreatLocker

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 13:50 UTC

Identified

User experience might be impacted. Any issues or assistance you might need, please reach out to support via LiveChat. We'll make sure to update this status page as we progress though this issue and towards its resolution. Thank you for your ongoing patience.
Posted Aug 01, 2025 - 19:43 UTC
This incident affected: Portal (Portal [Instance H]).