Slowness on the Applications page Instance G

Incident Report for ThreatLocker

Resolved

The cause of the performance degradation was quickly identified, and the implemented solution has resolved the issue. The incident has now been downgraded.
Posted Feb 24, 2026 - 16:24 UTC

Investigating

We are currently investigating and working on a remediation.
Posted Feb 24, 2026 - 16:15 UTC
This incident affected: Portal (Portal [Instance G]).